Excel Help plx.

  • Folgendes Problem mit Excel:


    Ich brauch ne Formel und zwar will ich folgendes machen.


    Ich habe zwei Spalten, angenommen von A1-A10 und B1-B10
    in jeder Zelle steht n datum, in jeder (20 daten also)


    Jetzt will ich unten anzeigen, das alle daten in spalte B gezählt werden sollen,
    die größter sind als das datum in spalte A, also das dann da unten steht "8" wenn zB
    8 daten in spalte B größer sind als in spalte A.


    Und noch eine Umkehrformel, das dann da steht "2" für die 2 Daten die dann zB
    kleiner sind als die in spalte A

  • Zwar nicht elegant, aber es geht:


    Du machst eine Hilfsspalte


    =WENN(B1>$A$X;1;0) (x durch dein gewünschtes Feld ersetzen)
    und ziehst das ganze nach durch, also bis
    =WENN(B10>$A$X;1;0)
    Wenn das Datum größer ist als spuckt die Formel 1 aus, ansonsten 0.


    und für die Zählung:


    =ZÄHLENWENN(C1:C10;1) (Anzahl Zellen größer)
    =ZÄHLENWENN(C1:C10;0) (Anzahl Zellen kleiner)


    Vielleicht fällt mir noch was schöneres ein..

  • So, ich hab's in zwei Zeilen:



    =ZÄHLENWENN(B1:B10;">="&Ax)
    =ZÄHLENWENN(B1:B10;"<"&Ax)

    Edited once, last by PeAzZe ().

  • Quote

    Original von PeAzZe
    So, ich hab's in zwei Zeilen:



    =ZÄHLENWENN(B1:B10;">="&Ax)
    =ZÄHLENWENN(B1:B10;"<"&Ax)


    das funzt aber net :(


    hab in A1 bis A4 immer den 01.02.2009 eingetragen und in B1 bis B4 gewechselt mit
    20.02.2009, 24.02.2009 etc


    dann =ZÄHLENWENN(B1:B4;">="&Ax) in nen leeres feld gesetzt Ergebnis 0


    und =ZÄHLENWENN(B1:B4;"<"&Ax) in nen leeres feld gesetzt Ergebnis 0

  • Es reicht, wenn du das Datum, nach dem gesucht wird, einmal einträgst, zB in A1


    Wenn du Werte B1 bis B4 hast, dann


    =ZÄHLENWENN(B1:B4;">="&A1)
    =ZÄHLENWENN(B1:B4;"<"&A1)

  • Achso, du willst den Maximalwert von A haben? Falls ja, dann


    Code
    1. =ZÄHLENWENN(B1:B4;">="&MAX(A1:A4)) =ZÄHLENWENN(B1:B4;"<"&MAX(A1:A4))


    (blöde Smileys)

    Edited 2 times, last by PeAzZe ().

  • [Blocked Image: http://www.bilder-space.de/thumb/07.06nesNbS7oFvtpAe9.jpg]


    das sollte es erklären, mein problem^^


    das wird ne liste mit ca 45 daten, also 2 x 45 daten in den spalten


    und ich brauche die zahl, wie oft in der zweiten spalte das datum niedriger ist


    und ich brauche die zahl, wie oft in der zweiten spalte das datum größer ist

  • Quote

    Original von PeAzZe
    Größer oder kleiner als was?..


    siehste doch auf dem screen, die formel muss gucken, ob das datum in spalte b
    größer ist als das in spalte A, für alle daten in spalte B, die größer sind als in spalte A
    soll es zählen, sodass am ende unten steht, wie viele daten größer sind als A


    und genau so auch umgekehrt


    zweite formel soll gucken, wie oft das datum der spalte B kleiner ist als in A und
    auch das zählen damit ich das unten stehen hab.

  • Sorry, aber aus deinem Geschreibsel werde ich nicht schlau.


    Soll geprüft werden, ob B1 größer / kleiner A1 ist, also soll zellenweise verglichen werden, oder soll geprüft werden, ob B1 größer als A1,A2,A3 und A4 ist, also Zelle mit Spalte vergleichen?

  • Dafür brauchst du dann eine Hilfsspalte:


    =WENN(B1>A1;1;0)
    =WENN(B2>A2;1;0)
    etc.
    und dann nach unten ziehen. Falls Bx > Ax steht dann 1 in der entsprechenden Zelle, ansonsten 0. Um das ganze zu zählen nimmst du wieder (hier ist die Hilfsspalte in Spalte C)
    =ZÄHLENWENN(C1:C4;1) (Anzahl der Werte größer)
    =ZÄHLENWENN(C1:C4;0) (Anzahl der Werte kleiner)


  • verstanden, dann erklär kurz wat hilfsspalte is dann bin ich glücklich :D

  • Du markierst die gesamte Spalte, rechte Maustaste und dann ist da eine Option 'Ausblenden'